Back to overview
Maintenance
Server reboot
May 17, 2026 at 6:36pm UTC
–
May 17, 2026 at 6:41pm UTC
Affected services
alexradu.co
scouting.team1676.org
api.team1676.org
quizzr.org
Resolved
May 17, 2026 at 6:41pm UTC
Maintenance ended
Affected services
Created
May 17, 2026 at 6:36pm UTC
Everything will be down
Affected services